This application is a plugin for CyanogenMod's weather api's, providing real time weather data for any listeners from Weather Underground. It requires at least API level 5 or higher in the CyanogenMod build you're running.

Keyword: cyanogenmodweatherprovider
From version WU CM Weather Provider 1.1:
Fix partlycloudy weather code response
All versions