Please note that this application is merely a dependency of the full SU.
It won't install other needed parts of SU for you.

If you went here automatically, it means you installed my SU, and now you need the matching APK.
From version phh's SuperUser 1.0.3.3:
Support su --bind and su --init (needs update of boot.img)
All versions
January 15, 2016