Version: 7.1.1 (25)
59.13 MB (61,999,449 bytes)
Min: Android 7.1 (Nougat MR1, API 25)
Target: Android 7.1 (Nougat MR1, API 25)
Uploaded October 1, 2017 at 3:42PM UTC by Kelvin Cheung
Download APK

Whoa there!

It looks like you're using an ad blocker, so you'll have to wait 15 more seconds.
Please whitelist this site to skip the wait and help us pay for bandwidth, hosting, and other bills.

No description available
All versions
October 1, 2017
September 8, 2017
July 17, 2017
  • Jonathan

    Settings 7.1.1 an error occurred during package scan

    • farhan ali

      Same here

      • Jonathan


    • Robin Hugli

      guys its min api 25, it mean your minimum android version have to be 7.1.1, and only note 8 is on 7.1.1. so except if you have a note 8 you get package error

  • poeticRogue

    I have note 8, why did this have conflict installing?

    • Nadia Sanz

      same . cant install in note8

  • Black Goku 777

    Al que no pueda instalar touchwiz pásate por mi canal de youtube y tengo un tutorial si sos usuario rot